0

When submitting questions to *.stackexchange.com, I have to click several times, reload the page, close, open... (repeat until success)

This is because your website gets constantly blocked by my firewall, as I have reported in my meta question few days ago.

Now when i was submitting (and resubmitting) my question on security.stackexchange.com, my "behavior" has apparently raised suspicion and I was asked to prove I am human using this new Captcha.

The simple click on the button was not enough. I was asked to type the text. But I did not see any text. The field was blank.

I clicked on the sound/mp3 and downloaded the audio captcha. This is completely uncomprehensible. After downloading about 3-4 of them, I was finally able to distinguish the numbers. But then, The input field of the capthca did not work. I simply could not type the numbers.

Do I have to allow javascript from the whole internet just for your Captcha to work ?

UPDATE:

below is a screenshot of the captcha enter image description here

9
  • 3
    So the problem is your config, and you rant here? It works for everyone else, so perhaps first figure out what you have set up that causes these problems. This doesn't sound like a bug at all. – Rory Alsop Dec 13 '14 at 17:44
  • @Rory Alsop - Why do you think my "config" is the problem? My "config" works perfectly for all other sites. Besides, what is wrong with blocking unsolicited packets with firewall and using javascript to block execution of arbitrary code? – Martin Vegter Dec 13 '14 at 17:46
  • 2
    This site works perfectly well for millions of people. – Rory Alsop Dec 13 '14 at 18:46
  • The Captcha you are using looks strikingly similar to the brand new Captcha from Google, if I am not mistaken. How long have you been using it? I have allowed stackexchange.com in my "noscript" but the captcha did not work. Not sure whether that is relevant. (I am blocking some of google domains, though). My point with javascript is: in case you are sourcing captcha from other sites (google), then allowing stackexchange.com in noscript is obviously not enough. – Martin Vegter Dec 13 '14 at 18:51
  • I have no idea - I remember seeing it pop up that first time, I enabled it in NoScript - all good. – Rory Alsop Dec 13 '14 at 18:55
  • it's none of my business, but what use is NoScript if you blindly allow anything that pops up? – Martin Vegter Dec 13 '14 at 19:00
  • 2
    That's not how you use NoScript. You check the warning and enable if you are okay with it. – Rory Alsop Dec 13 '14 at 19:01
  • 3
    Post screenshots, please. Browser error logs too, if you have them. You can trigger a CAPTCHA by visiting security.stackexchange.com/captcha if you want to test that it's loading properly; the page should appear similar to this: i.stack.imgur.com/NJHZR.png - note that this depends on Google's reCAPTCHA service, so if that's being blocked at all you'll have a bad time. – Shog9 Dec 13 '14 at 19:27
  • @Shog9 - I have updated my question with the screenshot. As you can see, the text field is empty. Yes I am blocking some google domains (i.e. googleusercontent.com, google-analytics.com and similar). – Martin Vegter Dec 13 '14 at 19:38
6

Looking at the post you left on U&L, you are "using a rather restrictive firewall on my machine." Also, your first sentence here shows that something is wrong with your setup - you are opening and closing multiple times and it sometimes works.

On that other post, @Shog9 has explained what he thinks is the underlying problem with your setup. The downside for you is that your behaviour is making you look more like a bot than a human, so you need to pass a captcha.

Some days I need to pass a captcha here - depends on my behaviour. So far, so perfectly normal for the internet.

You having problems with the captcha again sounds very much down to the settings you have. You have pointed out that you block various things because you don't think you should have to use them - well, maybe you should figure out which things you are blocking are causing you the issues by trying turning them off to check behaviour.

I use a javascript blocker (NoScript) and all the Stack Exchange sites work perfectly well for me.

6

From your screenshot, it is clear that you (or someone with control over your network) is blocking the reCAPTCHA images, and possibly scripts as well. For your benefit, here's a quick list of things that load as part of my (working) CAPTCHA that may not be loading for your (broken) one:

http://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js
http://www.google.com/recaptcha/api/challenge?k=6LdsB7sSAAAAAAzjgEF_Hd8vXv-C42sa_KyofaGR&hl=en
http://www.google.com/recaptcha/api/challenge?k=6LdsB7sSAAAAAAzjgEF_Hd8vXv-C42sa_KyofaGR&hl=en
http://www.google.com/recaptcha/api/js/recaptcha.js
http://www.google.com/js/th/IzEZAfeaN9CyfeoKUP4DWoA1X9aNV9f1ZVSz6xxjtqw.js
http://www.google.com/recaptcha/api/img/clean/refresh.png
http://www.google.com/recaptcha/api/img/clean/audio.png
http://www.google.com/recaptcha/api/img/clean/text.png
http://www.google.com/recaptcha/api/img/clean/help.png
http://www.google.com/recaptcha/api/img/clean/logo.png
http://www.google.com/recaptcha/api/reload?c=03AHJ_Vuv9th9NkA3svkn_ztiJYA0Bt8jJrhIlqwIV6s2cEgcKMgY1G9_T8Iyb4CiUl80z888JtItSkbdsZj5swZ6TJOknixmM6dsc__SQLn0SnWBPRCnRYg-Colm0cnGSf6f0VjcbFj4vlzXaT9UJTmRbzxFMLFZgghXfYsOl8EJ0MFrXi1ag6F55gCN1N7zC8wDUqsovExZisozupTjoJ12VujDtxdB3rQ&k=6LdsB7sSAAAAAAzjgEF_Hd8vXv-C42sa_KyofaGR&reason=i&type=image&lang=en&th=,8bBVu20Qczj797YpPtJMP9C_N_AAAAAioAAAAAXYAMwhmeWx679XvRvKe6Rzuhqu5NXgIy8m8VISDp6puACRUJ09HT-MHNwoeu2GNhdMDLfYh88yMhtillsNs2_DgSWULXiu25q4ssd6VCgTi1ZprkbizHYHoUjGU3ek5VFJj-tWkfVGts2sx9DAYV6zHluoUznaovZb65F_zzu_3V3AwHREO7cYnzpLTtYQnJk6bxHG-J7BD2JbdRHg7NOOiG4ocIkr7UT47QFZrBtOYiS1dOmiWr0cS75EuUMm4W8-UMQeiKHvyE_VdfWHhQc
http://www.google.com/recaptcha/api/image?c=03AHJ_VuvhRZFuVG9_geqyqW6xpxrhHxKMGrh_BJcN3-fxaKXFw-LDWH44kXOMSRLdBiISVxMiBI-G5M-8fqT4pq3f7ZdNVtUknW8770gkUHrtPBnKClzim3xcZmYC95JD29VvxkEcEYjtMyEvexmUIzAWh40HzX_R6i6kxVmd1-oDEuNIqte8yf8XwJkPq0m5y4fB65oGEURPy_k1FEsylTkSuE0N6PMX9w&th=,8bBVu20Qczj797YpPtJMP9C_N_AAAAAioAAAAATYAMwhmeWx679XvRvKe6Rzuhqu5NXgIy8m8VISDp6puACRUJ09HT-MHNwoeu2GNhdMDLfYh88yMhtillsNs2_DgSWULXiu25q4ssd6VCgTi1ZprkbizHYHoUjGU3ek5VFJj-tWkfVGts2sx9DAYV6zHluoUznaovZb65F_zzu_3V3AwHREO7cYnzpLTtYQnJk6bxHG-J7BD2JbdRHg7NOOiG4ocIkr7UT47QFZrBtOYiS1dOmiWr0cS75EuUMm4W8-UMQAEaHvqZE28rvp_Aw

You'll need to determine what is blocking these, and then work to ensure that the relevant domains are whitelisted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .